Our team is actively monitoring the situation, and we’re seeing signs that services are gradually being restored. Some features may begin functioning again, but full stability is not yet guaranteed.
The team is continuing to monitor for full stability.
Posted Dec 02, 2025 - 07:19 PST
Investigating
We are currently experiencing a system-wide outage affecting multiple features. Our development team is actively investigating and working to restore full functionality as quickly as possible.
We will provide updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Dec 02, 2025 - 07:10 PST
This incident affected: MoeGo Mobile App and MoeGo Web Version.