Resolved: Our service provider has made significant progress in restoring the live chat systems following the earlier major cloud provider outage. While systems are recovering, you may still experience occasional slowness or degraded performance. We are actively monitoring the situation.
Posted Oct 20, 2025 - 13:48 PDT
Update
Our service provider is continuing to work on bringing the live chat systems fully back on track following our cloud provider’s major outage. While recovery progresses, customers may still experience slowness or degraded performance. We will keep monitoring it for full recovery.
Posted Oct 20, 2025 - 05:52 PDT
Monitoring
Our live chat platform Intercom is in recovery. More updates will be provided once stability is confirmed
Our live support chat platform Intercom is experiencing an outage. During this time, live chat support is unavailable. You can follow up on Intercom's status page in this link https://www.intercomstatus.com/us-hosting . We will provide update once live chat becomes operational.