Email Campaign Currently Unavailable

Incident Report for MoeGo

Resolved

The Email Campaign functionality has been restored. You can use email campaigns again without any issue. Thank you for your patience while we worked with the provider on a resolution :)
Posted Jan 20, 2026 - 16:17 PST

Identified

The Email Campaign feature is currently unavailable, and emails are not being delivered. We’ve identified the root cause and are working to resolve it as quickly as possible.
Posted Jan 18, 2026 - 22:53 PST
This incident affected: Email.