Service Slowness + Timeouts

Incident Report for MoeGo

Resolved

System failures have stopped. Performance has been resolved and we have returned to our normal system baseline. This incident has been resolved.

07:22 to 07:53: Increased latency began (slowness; no errors initially), customers reporting system slowing and timeouts
07:53 to 08:25: Intermittent errors began (some actions failed), customers cannot log in or navigate site
08:25 to 08:32: failures stopped; recovery period with improving performance
08:32 onward: Full recovery confirmed (back to normal baseline)
Posted Jan 23, 2026 - 08:32 PST

Monitoring

Update: We are currently experiencing system slowness and intermittent login failure. Our team is actively working to restore system speed and stability. We will keep you updated
Posted Jan 23, 2026 - 07:53 PST

Investigating

We’re currently experiencing slower than normal performance in MoeGo, resulting in low loading times and intermittent timeouts. Our team is working to restore full speed. Please try again in a few minutes. Thanks for your patience.
Posted Jan 23, 2026 - 07:22 PST
This incident affected: MoeGo Mobile App and MoeGo Web Version.