SMS messaging service down in MoeGo

Incident Report for MoeGo

Resolved

Resolved: Our messaging provider, Twilio, has reported a recovery in SMS capabilities and is currently monitoring for ongoing stability. You may have already experienced improvements in your ability to send text messages throughout the day as their systems progressed toward resolution.

We will continue to monitor the situation closely and provide further updates if necessary. Thank you for your continued patience.
Posted Oct 20, 2025 - 15:57 PDT

Update

According to our vendor, Twilio, full recovery is in progress. We are continuing to monitor it with Twilio and will provide an update once full stability is reached.
For more details, please check the link below for Twilio's status page update.
https://status.twilio.com/
Posted Oct 20, 2025 - 05:57 PDT

Monitoring

SMS messaging is in recovery as AWS services begin to recover. Based on reports from our vendor Twilio, services may still experience disruptions. We are monitoring this with Twilio and will provide update once full stability is reached.
More details: https://status.twilio.com/
Posted Oct 20, 2025 - 03:29 PDT

Investigating

MoeGo's messaging (powered by Twilio) is experiencing an outage due to a major outage by their cloud provider AWS (Amazon Web Services). All outbound SMS are not available at the moment. We will provide updates as services recover.
For more details, please check the link below for Twilio's status page update.
https://status.twilio.com/
Posted Oct 20, 2025 - 01:21 PDT
This incident affected: Messaging.